Double Relay 1981 Fiat Spider

The forum for all of your technical questions on your classic FIAT autos
Post Reply
silvway
Posts: 3
Joined: Mon Sep 10, 2018 9:53 am
Last Name: Silver
First Name: Wayne

Double Relay 1981 Fiat Spider

Post by silvway » Wed Sep 12, 2018 6:31 pm

Did these test with a home made test lamp
rlay tests.jpeg
rlay tests.jpeg (85.31 KiB) Viewed 152 times
and a voltmeter. The lamp did not light and the meter register 0 volts. Assuming I did the tests correctly and the apparatus were working, would this mean the relay was bad. I am getting correct diagnostics with the tests at the coloured wires but nothing at the white wires. Am I correct to assume that the coloured wires are not connecting through the relay to the white wires? I am not mechanically inclined and am rather uncertain to go ahead and purchase a new double relay. Are they prone to failure?
User avatar
bartigue
cinquemila club
Posts: 5741
Joined: Sat Jan 23, 2016 11:49 pm
Last Name: Artigue
First Name: Bradley
Contact:

Re: Double Relay 1981 Fiat Spider

Post by bartigue » Wed Sep 12, 2018 8:29 pm

If you are getting no output to the white wires then yes, the relay is bad. From a relay perspective the white side is the FI harness - the "output" side. I am assuming of course the fuel injection system isn't working and the car will not start?

Of course check your fuses, the one for the FI system isn't in the fuse box but is floating around under the driver's side dash near the steering column.
-----------------------------------------------------------
Brad Artigue
1982 Spider 2000
I've restored, worked on, sold, bartered, and bled for:
1970, 1979, 1980, 1981, 1982 124 Spiders -- 1969, 1970 850 Spiders -- 77 X1/9
http://fiat.artigue.com
spider2081
Posts: 396
Joined: Sun Jan 24, 2016 9:36 pm
Last Name: Laborde
First Name: Dave

Re: Double Relay 1981 Fiat Spider

Post by spider2081 » Thu Sep 13, 2018 7:45 am

The lamp did not light and the meter register 0 volts.
I have trouble seeing the connector pin numbers however it looks like your tests were made using terminal 85 in the white wire connector. This terminal connects to the ECU connector pin 28. The ECU completes the ground connection for the double relay by having internal connections between pins 28,16 and 17. Pins 16 and 17 have brown wires on them that are grounded in the engine compartment through the intake manifold mounting bolts closest to the firewall.
The test procedure you are following is only valid when you have the ECU plugged in and when you have tested and confirmed relay terminal 85 is connected to ground. Your tests could be telling you that terminal 85 is not grounded.
searya
Posts: 115
Joined: Sat Feb 24, 2018 12:24 am
Last Name: Ryan
First Name: Sean

Re: Double Relay 1981 Fiat Spider

Post by searya » Thu Sep 13, 2018 8:15 pm

spider2081 wrote:
Thu Sep 13, 2018 7:45 am
The lamp did not light and the meter register 0 volts.
I have trouble seeing the connector pin numbers however it looks like your tests were made using terminal 85 in the white wire connector. This terminal connects to the ECU connector pin 28. The ECU completes the ground connection for the double relay by having internal connections between pins 28,16 and 17. Pins 16 and 17 have brown wires on them that are grounded in the engine compartment through the intake manifold mounting bolts closest to the firewall.
The test procedure you are following is only valid when you have the ECU plugged in and when you have tested and confirmed relay terminal 85 is connected to ground. Your tests could be telling you that terminal 85 is not grounded.
That is a good point. I actually did the tests and was getting failing a bunch and then realized I had the CPU unplugged. Replugged it in and I was back in business!
Sean
1984 Pininfarina Azzura
Saint Louis, Mo
silvway
Posts: 3
Joined: Mon Sep 10, 2018 9:53 am
Last Name: Silver
First Name: Wayne

Re: Double Relay 1981 Fiat Spider

Post by silvway » Fri Sep 14, 2018 8:44 pm

Thanks. That is exactly what I did. Diagnostics for the relay are now OK.
silvway
Posts: 3
Joined: Mon Sep 10, 2018 9:53 am
Last Name: Silver
First Name: Wayne

Re: Double Relay 1981 Fiat Spider

Post by silvway » Fri Sep 14, 2018 8:48 pm

I would like to thank everyone for their help. I made a mistake with my tests as I had the ECU not connected. But on the bright side I made some real improvements to my homemade test lamp and it works great.
Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests